Список предметов
Как использовать формулы в Excel
2 / 15
Развернуть структуру обучения Свернуть структуру обучения

Задание 1

Таблица для определения премии с помощью Excel

1. Построим таблицу, которая будет отображать выторг четырех филиалов за шесть месяцев. Заполним таблицу данными.

2. Посчитаем выручку каждого филиала от продаж. Это можно сделать с помощью функции СУММ (начало диапазона : конец диапазона) Указываем диапазон для каждого филиала.

3. Посчитаем премию 1. В условии сказано, что премия должна выплачиваться филиалам, которые пересекли рубеж в 1600 тысяч гривен. Премия должна составлять 3 процента от всего выторга филиала. Так как у нас несколько условий, воспользуемся функцией ЕСЛИ и построим формулу нахождения величины премии при заданных условиях =ЕСЛИ(B10>=1600;B10*3%;0)

Первая часть формулы (B10>=1600) задает условие, при котором будет выполняться следующее за ней выражение (B10*3%). При невыполнении условия (B10>=1600) будет выполняться последнее выражение. В нашем случае это цифра 0. Так как при невыполнении условия выплаты премия не выплачивается.

4. Построим формулу для вычисления премии 2. Теперь у нас даны несколько условий. Премия выплачивается, если выторг находится в рамках 1600-2500 тысяч гривен (премия равна 3% от выторга), если выторг находится в рамках2500-3500 тысяч гривен (премия равна 5% от выторга), если выторг больше 3500 тысяч гривен (премия равна 7% от выторга), премия не выплачивается, если выторг меньше 1600 тысяч гривен. Воспользуемся функцией ЕСЛИ и возможностями переходящего условия.

=ЕСЛИ(B10>3500;B10*7%;ЕСЛИ(B10>2500;B10*5%;ЕСЛИ(B10>1600;B10*3%;0))). Разберемся, как работает переходящее условие. В предыдущем задании мы поняли, по какому принципу выполняются выражения в функции если. Переходящее условие это просто одно из таких выражений, которое будет выполняться. 

Возьмем кусочек формулы ЕСЛИ(B10>2500;B10*5%;ЕСЛИ(B10>1600… 

Красным цветом обозначено условие, при выполнении которого будет выполняться выражение зеленого цвета. При невыполнении условия (красный цвет), будет выполняться выражение синего цвета

Это функция если. Она встроена в нашу формулу. Это и называется переходящим условием. Встроенная функция ЕСЛИ будет работать по стандартному принципу. В нашей формуле несколько раз используется переходящее условие. Обязательно нужно следить за синтаксисом нашей формулы, так как у нас используются несколько функций ЕСЛИ. В связи с этим не забываем ставить нужное количество скобочек в конце формулы, иначе формула будет просто неправильной. Современные версии программы Excel могут автоматически исправить эту ошибку.

5. Построим формулу для вычисления премии 3. Теперь премия выдается в зависимости от места по размеру общего выторга, которое занимает филиал. Первое место – 7% от общего выторга филиала, второе место – 5% от общего выторга филиала, третье место – 3% от общего выторга филиала, последнее место – 1% от общего выторга филиала. Такую формулу можно построить с помощью функций ЕСЛИ и НАИБОЛЬШИЙ и переходящего условия.

=ЕСЛИ(НАИБОЛЬШИЙ($B$10:$E$10;1)=B10;B10*0,07;ЕСЛИ(НАИБОЛЬШИЙ($B$10:$E$10;2)=B10;B10*0,05;ЕСЛИ(НАИБОЛЬШИЙ($B$10:$E$10;3)=B10;B10*0,03;ЕСЛИ(НАИБОЛЬШИЙ($B$10:$E$10;4)=B10;B10*0,01)))). 

Разберемся как работает эта формула. Возьмем часть формулы =ЕСЛИ(НАИБОЛЬШИЙ($B$10:$E$10;1)=B10;B10*0,07;ЕСЛИ(НАИБОЛЬШИЙ($B$10:$E$10;2)=B10…. 

Поймем, как работает функция наибольший. Функция НАИБОЛЬШИЙ показывает наибольшее значение в указанном диапазоне выторгов всех филиалов, или является ли это значение наибольшим на месте, которое мы можем задать (допустим места 1,2,3,4. Так как у нас 4 места). Значок $ позволяет закрепить значения в формуле, это позволяет копировать формулу без изменения значений, выделенных этим знаком (диапазон для функции НАИБОЛЬШИЙ один для всех ячеек, где используется эта формула). Теперь поймем, как работает сама формула. 

ЕСЛИ НАИБОЛЬШЕЕ значение (смотрим на красную часть формулы) в указанном диапазоне и на указанном месте является наибольшим, то выполняется условие (смотрим на зеленую часть формулы), если условие не выполняется, то выполняется синяя часть формулы (используется возможность переходящего условия). Мы рассмотрели часть формулы, которая отвечает за выплату премии для первого места. По такому же принципу происходит расчет выплат премии для остальных мест. Не забываем ставить нужное количество скобочек в конце формулы.

Задание 2

Использование формул для группировки данных по регионам

1. Рассчитаем величину экспорта и импорта с помощью функции СУММ и указанного диапазона Экспорта и импорта.

2. Рассчитаем сальдо с помощью формулы =ABS(Экспорт-Импорт). Используем ABS для изменения отрицательных значений в положительные, так как сальдо не может быть отрицательным.

Задание 3

Использование формул для определения данных отвечающих условию

1. Вводим значения, изменив формат ячеек на дату.

2. С помощью функции ДНЕЙ360 построим формулу для определения количества дней до истечения срока реализации =ДНЕЙ360(Дата выпуска;Конечный срок реализации;).

3. В этом задании нам нужно сделать так, чтобы в столбце таблицы ”Примечание” выдавало самый свежий товар. С помощью функции ЕСЛИ и МАКС построим формулу, выполняющую условия задания =ЕСЛИ(D5=МАКС($D$5:$D$12);"САМЫЙ СВЕЖИЙ ТОВАР";""). Разберемся, как работает функция. Нам нужно чтобы при Максимальном количестве дней до окончания срока реализации выбивало значение "САМЫЙ СВЕЖИЙ ТОВАР". Воспользуемся функцией ЕСЛИ. Если значение на указанном промежутке максимальное (в нашем случае это диапазон столбца конечных сроков реализации) то будет выполняться следующее условие, будет выбиваться нужное нам предложение. Если же условие не будет выполняться, то не будет выбиваться ничего.

0  


 Использование электронных таблиц Excel | Описание курса | Как импортировать информацию из базы данных 
   

Обсудить на форуме
Записаться на курсы
Обратиться к консультанту
Пройти тест
Полный список курсов обучения
Бесплатные видеоуроки
Нужна информация!




Нажмите, чтобы рекомендовать эту страницу другим:
Рейтинг@Mail.ru